MariaDB 10.3.0 < 10.3.29 多个漏洞

medium Nessus 插件 ID 149030

简介

远程数据库服务器受到多个漏洞的影响

描述

远程主机上安装的 MariaDB 版本低于 10.3.29。因此,该主机受到 mariadb-10329-release-notes 公告中提及的多个漏洞影响。

- Oracle MySQL 的 MySQL Server 产品中存在漏洞(组件:服务器:DML)。支持的版本中受影响的是 5.7.33 和较早版本。可轻松利用的漏洞允许高权限攻击者通过多种协议进行网络访问,从而破坏 MySQL Server。成功利用此漏洞进行攻击可导致在未经授权的情况下造成 MySQL Server 挂起或频繁出现崩溃(完整 DOS)。(CVE-2021-2154)

- Oracle MySQL 的 MySQL Server 产品中存在漏洞(组件:服务器:DML)。支持的版本中受影响的是 5.7.33 和较早版本以及 8.0.23 和较早版本。可轻松利用的漏洞允许高权限攻击者通过多种协议进行网络访问,从而破坏 MySQL Server。成功利用此漏洞进行攻击可导致在未经授权的情况下造成 MySQL Server 挂起或频繁出现崩溃(完整 DOS)。(CVE-2021-2166)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级至 MariaDB 10.3.29 或更高版本。

另见

https://mariadb.com/kb/en/mariadb-10329-release-notes

插件详情

严重性: Medium

ID: 149030

文件名: mariadb_10_3_29.nasl

版本: 1.3

类型: remote

系列: Databases

发布时间: 2021/4/27

最近更新时间: 2022/5/9

配置: 启用偏执模式

风险信息

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 4

时间分数: 3

矢量: AV:N/AC:L/Au:S/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2021-2166

CVSS v3

风险因素: Medium

基本分数: 4.9

时间分数: 4.3

矢量: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:mariadb:mariadb

必需的 KB 项: Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2021/4/27

漏洞发布日期: 2021/4/20

参考资料信息

CVE: CVE-2021-2154, CVE-2021-2166, CVE-2022-21451