Jenkins LTS < 2.277.3 / Jenkins(每周)< 2.286

high Nessus 插件 ID 148975

简介

远程 Web 服务器主机上运行的应用程序受到一个漏洞的影响

描述

根据其自我报告的版本号,远程 Web 服务器上运行的 Jenkins 版本低于 Jenkins LTS 2.277.3,或低于 Jenkins weekly 2.286。因此,该应用程序会受到漏洞的影响:

- 在 Eclipse Jetty 7.2.2 至 9.4.38、10.0.0.alpha0 至 10.0.1 和 11.0.0.alpha0 至 11.0.1 中,CPU 使用率可在接收大型无效 TLS 框架时达到 100%。(CVE-2021-28165)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级至 Jenkins weekly 2.286 或更高版本,或升级至 Jenkins LTS 2.277.3 或更高版本

另见

https://jenkins.io/security/advisory/2021-04-20

插件详情

严重性: High

ID: 148975

文件名: jenkins_2_286.nasl

版本: 1.4

类型: combined

代理: windows, macosx, unix

系列: CGI abuses

发布时间: 2021/4/23

最近更新时间: 2022/4/11

配置: 启用彻底检查

支持的传感器: Frictionless Assessment Agent, Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 5.1

CVSS v2

风险因素: High

基本分数: 7.8

时间分数: 5.8

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:C

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2021-28165

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:cloudbees:jenkins, cpe:/a:jenkins:jenkins

必需的 KB 项: installed_sw/Jenkins

易利用性: No known exploits are available

补丁发布日期: 2021/4/20

漏洞发布日期: 2021/4/1

参考资料信息

CVE: CVE-2021-28165