Drupal 7.x < 7.78 / 8.9.x < 8.9.13 / 9.x < 9.0.11 / 9.1.x < 9.1.3 目录遍历 (SA-CORE-2021-001)

high Nessus 插件 ID 148896
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器上运行的 PHP 应用程序受到一个漏洞的影响。

描述

根据其自我报告的版本,远程 Web 服务器上运行的 Drupal 实例为低于 7.78 的 7.x,低于 8.9.13 的 8.9.x、低于 9.0.11 的 9.x 或低于 9.1.3 的 9.1.x。因此,该操作系统受到漏洞的影响。

- 在 Archive_Tar 1.4.11 及之前的所有版本中,由于对符号链接的检查不充分,导致 Tar.php 允许用户通过目录遍历执行写入操作,此问题与 CVE-2020-28948 相关。(CVE-2020-36193)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级版本到 Drupal 7.78 / 8.9.13 / 9.0.11 / 9.1.3 或更高版本。

另见

https://www.drupal.org/sa-core-2021-001

https://www.drupal.org/project/drupal/releases/7.78

https://www.drupal.org/project/drupal/releases/8.9.13

https://www.drupal.org/project/drupal/releases/9.0.11

https://www.drupal.org/project/drupal/releases/9.1.3

插件详情

严重性: High

ID: 148896

文件名: drupal_9_1_3.nasl

版本: 1.3

类型: remote

系列: CGI abuses

发布时间: 2021/4/21

最近更新时间: 2021/4/22

依存关系: drupal_detect.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2020-36193

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:drupal:drupal

必需的 KB 项: installed_sw/Drupal, Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2021/1/20

漏洞发布日期: 2021/1/18

参考资料信息

CVE: CVE-2020-36193