MariaDB 10.4.0 < 10.4.18 漏洞

high Nessus 插件 ID 148827

简介

远程数据库服务器受到一个漏洞的影响

描述

远程主机上安装的 MariaDB 版本低于 10.4.18。因此,该数据库受到 mdb-10418-rn 公告中提及的一个漏洞的影响。

- 在 MariaDB 10.2 版 10.2.37 之前版本、10.3 版 10.3.28 之前版本、10.4 版 10.4.18 之前版本、和 10.5 版 10.5.9 之前版本,2021-03-03 之前的 Percona Server 以及 2021-03-03 之前 MySQL 的 wsrep 修补程序中发现一个远程代码执行问题。不受信任的搜索路径导致 eval 注入,其中数据库 SUPER 用户可在修改 wsrep_provider 和 wsrep_notify_cmd 后执行 OS 命令。注意:这不会影响 Oracle 产品。(CVE-2021-27928)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级至 MariaDB 10.4.18 或更高版本。

另见

https://mariadb.com/kb/en/mdb-10418-rn

插件详情

严重性: High

ID: 148827

文件名: mariadb_10_4_18.nasl

版本: 1.3

类型: remote

系列: Databases

发布时间: 2021/4/20

最近更新时间: 2021/4/21

配置: 启用偏执模式

风险信息

VPR

风险因素: High

分数: 7.4

CVSS v2

风险因素: High

基本分数: 9

时间分数: 7

矢量: AV:N/AC:L/Au:S/C:C/I:C/A:C

时间矢量: E:POC/RL:OF/RC:C

CVSS 分数来源: CVE-2021-27928

CVSS v3

风险因素: High

基本分数: 7.2

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:mariadb:mariadb

必需的 KB 项: Settings/ParanoidReport

可利用: true

易利用性: Exploits are available

补丁发布日期: 2021/2/22

漏洞发布日期: 2021/3/19

参考资料信息

CVE: CVE-2021-27928