Joomla 3.0.x < 3.9.26 多个漏洞 (5835-joomla-3-9-26)

medium Nessus 插件 ID 148641
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器上运行的 PHP 应用程序受到多个漏洞影响。

描述

根据其自我报告的版本,远程 Web 服务器上运行的 Joomla! 实例版本为低于 3.9.26 的 3.0.x。因此,该应用程序受到多个漏洞的影响:

- 默认模板页面的徽标参数中存在跨站脚本 (XSS) 漏洞,这是未正确验证用户提供的输入便将其返回给用户所致。未经身份验证的远程攻击者可利用此问题,通过诱使用户单击特制的 URL,在用户的浏览器会话中执行任意脚本代码 (CVE-2021-26030)。

- 在模块布局设置组件中存在一个本地文件包含漏洞。未经认证的远程攻击者可以利用此问题在远程主机上查看任意文件或执行任意 PHP 代码 (CVE-2021-26031)。

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级到 Joomla! 3.9.26 或更高版本。

另见

http://www.nessus.org/u?4fbda47c

http://www.nessus.org/u?27b06c66

http://www.nessus.org/u?e407311a

插件详情

严重性: Medium

ID: 148641

文件名: joomla_3926.nasl

版本: 1.6

类型: remote

系列: CGI abuses

发布时间: 2021/4/15

最近更新时间: 2021/5/28

依存关系: joomla_detect.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2021-26031

VPR

风险因素: Low

分数: 3.8

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:P/I:N/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 5.3

时间分数: 4.6

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:joomla:joomla%5c%21

必需的 KB 项: installed_sw/Joomla!, www/PHP, Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2021/4/13

漏洞发布日期: 2021/4/13

参考资料信息

CVE: CVE-2021-26030, CVE-2021-26031

IAVA: 2021-A-0179-S