Amazon Linux AMI:screen (ALAS-2021-1492)

critical Nessus 插件 ID 148377
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Amazon Linux AMI 主机缺少安全更新。

描述

远程主机上安装的 screen 版本低于 4.0.3-19.7。因此,该操作系统受到 ALAS-2021-1492 公告中提及的漏洞的影响。

- 远程攻击者可利用 GNU Screen 4.8.0 及之前版本中的 encoding.c,通过构建的 UTF-8 字符序列,造成拒绝服务(写入访问无效和应用程序崩溃)或其他不明影响。(CVE-2021-26937)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

运行“yum update screen”以更新系统。

另见

https://alas.aws.amazon.com/ALAS-2021-1492.html

https://access.redhat.com/security/cve/CVE-2021-26937

插件详情

严重性: Critical

ID: 148377

文件名: ala_ALAS-2021-1492.nasl

版本: 1.2

类型: local

代理: unix

发布时间: 2021/4/7

最近更新时间: 2021/4/7

依存关系: ssh_get_info.nasl

风险信息

CVSS 分数来源: CVE-2021-26937

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:amazon:linux:screen, p-cpe:/a:amazon:linux:screen-debuginfo, cpe:/o:amazon:linux

必需的 KB 项: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

易利用性: No known exploits are available

补丁发布日期: 2021/4/7

漏洞发布日期: 2021/2/9

参考资料信息

CVE: CVE-2021-26937

ALAS: 2021-1492