Squid 2.x < 4.14 / 5.x < 5.0.5(SQUID-2020: 11)

high Nessus 插件 ID 148111
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程代理服务器受到 HTTP 请求走私漏洞的影响

描述

根据其标题,远程主机上运行的 Squid 版本为低于 4.14 的 2.x 或低于 5.0.5 的 5.x。
因此,该应用程序受到 HTTP 请求走私漏洞的影响,这是未正确验证输入所致。配置设置中的某些 uri_whitespace 会发生这种情况。此问题允许受信任的客户端执行 HTTP 请求走私以及访问 Squid 安全控件原本禁止的服务。

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级到 Squid 4.14 或 5.05 或更高版本。

另见

http://www.nessus.org/u?94d2ab4c

插件详情

严重性: High

ID: 148111

文件名: squid_5_0_5.nasl

版本: 1.5

类型: remote

系列: Firewalls

发布时间: 2021/3/25

最近更新时间: 2021/4/1

依存关系: squid_version.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2020-25097

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:P/I:N/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 8.6

时间分数: 7.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:squid-cache:squid

必需的 KB 项: installed_sw/Squid, Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2021/2/8

漏洞发布日期: 2020/9/3

参考资料信息

CVE: CVE-2020-25097

IAVB: 2021-B-0021