NewStart CGSL CORE 5.04 / MAIN 5.04:libuser 多个漏洞 (NS-SA-2021-0044)

high Nessus 插件 ID 147366

语言:

全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程机器受到多个漏洞影响。

描述

运行 CORE 5.04 / MAIN 5.04 版本的远程 NewStart CGSL 主机上安装的 libuser 程序包受到多个漏洞的影响:

- 在低于 0.56.13-8 的 libuser 版本和低于 0.60-7 的 libuser 0.60 版本(用于 usermode 程序包的 userhelper 程序)中,可直接修改 /etc/passwd,本地用户可利用此漏洞,通过在修改期间构造错误,造成拒绝服务(不一致的文件状态)。注意:同时利用此问题和 CVE-2015-3245 即可获取权限。(CVE-2015-3246)

- 在低于 0.56.13-8 的 libuser 版本和低于 0.60-7 的 0.60 版本(用于 usermode 程序包的 userhelper 程序)中,chfn 函数存在黑名单不完整漏洞,本地用户可利用此漏洞,通过 GECOS 字段中的换行符,造成拒绝服务(/etc/passwd 损坏)。(CVE-2015-3245)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级易受攻击的 CGSL libuser 程序包。请注意,可能尚无可用的已更新程序包。请联系 ZTE 获取更多信息。

另见

http://security.gd-linux.com/notice/NS-SA-2021-0044

插件详情

严重性: High

ID: 147366

文件名: newstart_cgsl_NS-SA-2021-0044_libuser.nasl

版本: 1.3

类型: local

发布时间: 2021/3/10

最近更新时间: 2021/3/11

依存关系: ssh_get_info.nasl

风险信息

CVSS 分数来源: CVE-2015-3246

VPR

风险因素: Critical

分数: 9.6

CVSS v2

风险因素: High

基本分数: 7.2

时间分数: 6.3

矢量: AV:L/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:H/RL:OF/RC:C

漏洞信息

必需的 KB 项: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

可利用: true

易利用性: Exploits are available

补丁发布日期: 2021/3/9

漏洞发布日期: 2015/7/23

可利用的方式

Core Impact

Metasploit (Libuser roothelper Privilege Escalation)

参考资料信息

CVE: CVE-2015-3245, CVE-2015-3246

BID: 76021, 76022