Apache Tomcat 8.5.0 < 8.5.63 多种漏洞

high Nessus 插件 ID 147019

简介

远程 Apache Tomcat 服务器受到多个漏洞的影响。

描述

远程主机上安装的 Tomcat 版本低于 8.5.63。因此,该应用程序受到供应商公告中提及的多个漏洞的影响。

- 当使用 Apache Tomcat 版本 10.0.0-M1 到 10.0.0-M4、 9.0.0.M1 到 9.0.34、8.5.0 到 8.5.54 以及 7.0.0 到 7.0.103 时,如果出现以下情况:a) 攻击者能够控制服务器上文件的内容和名称;b) 服务器配置为将 PersistenceManager 与 FileStore 一起使用;c) 为 PersistenceManager 配置了 sessionAttributeValueClassNameFilter=null(未使用 SecurityManager 时,此为默认值)或者不太严格的过滤器,允许对攻击者提供的对象进行反序列化;d) 攻击者知道从 FileStore 使用的存储位置到其控制的文件的相对文件路径,则在使用特别构建的请求的情况下,该攻击者将能够通过反序列化其控制的文件来触发远程代码执行。请注意,从 a) 到 d) 的所有条件都必须为真,攻击才能成功。(CVE-2020-9484)

- 在响应新的 h2c 连接请求时,Apache Tomcat 版本 10.0.0-M1 - 10.0.0、9.0.0.M1 - 9.0.41 和 8.5.0 - 8.5.61 可将请求标头和有限的请求正文从一个请求复制到另一个请求中,这意味着用户 A 和用户 B 都可以看到用户 A 的请求结果。(CVE-2021-25122)

- 使用 Apache Tomcat 10.0.0-M1 - 10.0.0、9.0.0.M1 - 9.0.41、8.5.0 - 8.5.61 或 7.0.0. - 7.0.107 处理极不可能遇到的配置边缘情况时,Tomcat 实例仍然容易受到 CVE-2020-9494 的影响。请注意,之前发布的 CVE-2020-9484 先决条件和之前发布的 CVE-2020-9484 缓解措施同样适用于此问题。(CVE-2021-25329)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级到 Apache Tomcat 8.5.63 版本或更高版本。

另见

http://www.nessus.org/u?b6278e74

http://www.nessus.org/u?0be223a3

http://www.nessus.org/u?15b6baad

插件详情

严重性: High

ID: 147019

文件名: tomcat_8_5_63.nasl

版本: 1.9

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2021/3/4

最近更新时间: 2022/4/28

配置: 启用彻底检查

支持的传感器: Nessus Agent

风险信息

VPR

风险因素: High

分数: 8.4

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.9

矢量: AV:N/AC:L/Au:N/C:P/I:N/A:N

时间矢量: E:POC/RL:OF/RC:C

CVSS 分数来源: CVE-2021-25122

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.7

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:tomcat

必需的 KB 项: installed_sw/Apache Tomcat

可利用: true

易利用性: Exploits are available

补丁发布日期: 2021/1/28

漏洞发布日期: 2021/2/2

参考资料信息

CVE: CVE-2020-9484, CVE-2021-25122, CVE-2021-25329

IAVA: 2021-A-0114-S