PHP 7.3.x < 7.3.27 / 7.4.x < 7.4.15 / 8.x < 8.0.2 DoS

high Nessus 插件 ID 146311
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器上运行的 PHP 版本受到拒绝服务漏洞的影响。

描述

远程主机上安装的 PHP 版本为低于 7.3.27 的 7.3.x、低于 7.4.15 的 7.4.x 或低于 8.0.2 的 8.x。
因此,PHP 受到拒绝服务 (DoS) 漏洞的影响,这是 SoapClient 中的空取消引用所致。未经身份验证的远程攻击者可以利用此漏洞,通过向不存在现有字段的 SoapCLient query() 函数提供 XML,导致 PHP 崩溃。

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本

解决方案

升级至 PHP 7.3.27、7.4.15、8.0.2 或更高版本。

另见

https://www.php.net/ChangeLog-7.php#7.3.27

https://www.php.net/ChangeLog-7.php#7.4.15

https://www.php.net/ChangeLog-8.php#8.0.2

插件详情

严重性: High

ID: 146311

文件名: php_8_0_2.nasl

版本: 1.5

类型: remote

系列: CGI abuses

发布时间: 2021/2/9

最近更新时间: 2021/6/3

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2021-21702

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP, installed_sw/PHP

易利用性: No known exploits are available

补丁发布日期: 2021/2/4

漏洞发布日期: 2021/2/4

参考资料信息

CVE: CVE-2021-21702

IAVA: 2021-A-0082-S