pfSense 2.4.x < 2.4.5-p1 多个漏洞

high Nessus 插件 ID 146206
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程防火墙主机受到多个漏洞影响。

描述

根据其自我报告的版本号,远程 pfSense 的安装版本为低于 2.4.5-p1 的 2.4.x 版。因此,受到以下子组件中的漏洞影响:

- Unbound 1.10.1 之前版本中存在对网络消息容量控制不充分的问题,亦称 NXNSAttack 问题。此问题由 NS 记录中 NSDNAME 中的随机子域触发。(CVE-2020-12662)

- Unbound 1.10.1 之前版本中存在通过从上游服务器接收的畸形 DNS 应答造成的无限循环。
(CVE-2020-12663)

- 在 json-c 0.14 及之前的版本中,存在通过大型 JSON 文件造成整数溢出和越界写入的漏洞,printbuf_memappend 即为一例。(CVE-2020-12762)

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号。

解决方案

升级至 pfSense 2.4.5-p1 或更高版本,或应用供应商公告中提及的补丁程序。

另见

https://docs.netgate.com/pfsense/en/latest/releases/2-4-5-p1.html

插件详情

严重性: High

ID: 146206

文件名: pfsense_2_4_5_p1.nasl

版本: 1.2

类型: remote

系列: Firewalls

发布时间: 2021/2/4

最近更新时间: 2021/2/5

依存关系: pfsense_detect.nbin

风险信息

CVSS 分数来源: CVE-2020-12762

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.8

时间分数: 6.8

矢量: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense, cpe:/a:netgate:pfsense

必需的 KB 项: Host/pfSense

易利用性: No known exploits are available

补丁发布日期: 2020/6/9

漏洞发布日期: 2020/5/9

参考资料信息

CVE: CVE-2020-12662, CVE-2020-12663, CVE-2020-12762