Apache Struts 2.x < 2.5.26 RCE (S2-061)(直接检查)

critical Nessus 插件 ID 144365

简介

远程主机上安装的 Apache Struts 会受到远程代码执行漏洞的影响。

描述

远程主机上安装的 Apache Struts 版本为低于 2.5.26 的 2.x 版。因此,由于用户输入验证不足,它在其 OGNL 评估功能中会受到远程代码执行漏洞的影响。未经身份验证的远程攻击者可利用此漏洞,在受影响的主机上执行任意命令。

解决方案

升级版本到 Apache Struts 2.5.26 或更高版本。或者,应用供应商安全公告中提及的变通方案。

另见

http://www.nessus.org/u?11829f39

https://cwiki.apache.org/confluence/display/WW/S2-061

插件详情

严重性: Critical

ID: 144365

文件名: struts_cve_2020_17530.nbin

版本: 1.22

类型: remote

系列: CGI abuses

发布时间: 2020/12/17

最近更新时间: 2022/8/15

配置: 启用彻底检查

风险信息

VPR

风险因素: High

分数: 8.4

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:H/RL:OF/RC:C

CVSS 分数来源: CVE-2020-17530

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 9.4

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:H/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:struts

排除的 KB 项: Settings/disable_cgi_scanning

可利用: true

易利用性: Exploits are available

补丁发布日期: 2020/12/6

漏洞发布日期: 2020/12/8

CISA 已知利用日期: 2022/5/3

可利用的方式

Metasploit (Apache Struts 2 Forced Multi OGNL Evaluation)

参考资料信息

CVE: CVE-2020-17530

IAVA: 2020-A-0565