IBM HTTP Server 7.0.0.0 <= 7.0.0.45 / 8.0.0.0 <= 8.0.0.15 / 8.5.0.0 < 8.5.5.18 / 9.0.0.0 < 9.0.5.4 多个漏洞 (6191631)

medium Nessus 插件 ID 144070
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器受到多个漏洞影响。

描述

在远程主机上运行的 IBM HTTP Server 版本受到与 Apache HTTP Server 相关的多个漏洞的影响,如下所示:

- 在 Apache HTTP Server 2.4.0 至 2.4.41 中,使用 mod_rewrite 配置的重定向(原本应自引用)可能受到编码的新行欺骗,并重定向至请求 URL 中的非预期 URL。(CVE-2020-1927)

- 在 Apache HTTP 服务器 2.4.0 至 2.4.41 中,代理到恶意 FTP 服务器时,mod_proxy_ftp 可能使用未初始化的内存。(CVE-2020-1934)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级到 IBM HTTP Server 版本 8.5.5.18、9.0.5.4 或更高版本。或者,升级到临时补丁所需的最低 Fix Pack 级别,然后应用临时补丁 PH21992。

另见

https://www.ibm.com/support/pages/node/6191631

插件详情

严重性: Medium

ID: 144070

文件名: ibm_http_server_6191631.nasl

版本: 1.3

类型: local

代理: unix

系列: Web Servers

发布时间: 2020/12/10

最近更新时间: 2021/1/25

依存关系: ibm_http_server_nix_installed.nbin

风险信息

CVSS 分数来源: CVE-2020-1927

VPR

风险因素: Low

分数: 3.8

CVSS v2

风险因素: Medium

基本分数: 5.8

时间分数: 4.3

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 6.1

时间分数: 5.3

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:ibm:http_server

必需的 KB 项: installed_sw/IBM HTTP Server (IHS)

易利用性: No known exploits are available

补丁发布日期: 2020/4/15

漏洞发布日期: 2020/4/1

参考资料信息

CVE: CVE-2020-1927, CVE-2020-1934