PostgreSQL 9.5.x < 9.5.24 / 9.6.x < 9.6.20 / 10.x < 10.15 / 11.x < 11.10 / 12.x < 12.5 / 13.x < 13.1 多个漏洞

high Nessus 插件 ID 144060
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程数据库服务器受到多个漏洞的影响

描述

远程主机上安装的 PostgreSQL 版本为低于 9.5.24 的 9.5、低于 9.6.20 的 9.6、低于 10.15 的 10、低于 11.10 的 11、低于 12.5 的 12 或低于 13.1 的 13。因此,该数据库可能受到多个漏洞的影响:
- 多种功能可逃避安全性受限的操作沙箱 (CVE-2020-25695)
- 重新连接可使连接安全设置降级 (CVE-2020-25694)
- psql 的 gset 使得可以覆盖经过特殊处理的变量 (CVE-2020-25696) 请注意,Nessus 没有测试此问题,而仅依赖于应用程序自我报告的版本号。

解决方案

升级至 PostgreSQL 9.5.24 / 9.6.20 / 10.15 / 11.10 / 12.5 / 13.1 或更高版本

另见

http://www.nessus.org/u?ccdf09f5

https://access.redhat.com/security/cve/CVE-2020-25695

https://access.redhat.com/security/cve/CVE-2020-25694

https://access.redhat.com/security/cve/CVE-2020-25696

插件详情

严重性: High

ID: 144060

文件名: postgresql_20201112.nasl

版本: 1.7

类型: combined

代理: windows, macosx, unix

系列: Databases

发布时间: 2020/12/10

最近更新时间: 2021/6/18

依存关系: postgres_installed_windows.nbin, postgres_installed_nix.nbin, postgresql_version.nbin

风险信息

CVSS 分数来源: CVE-2020-25696

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.6

时间分数: 5.6

矢量: AV:N/AC:H/Au:N/C:C/I:C/A:C

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:postgresql:postgresql

易利用性: No known exploits are available

补丁发布日期: 2020/11/12

漏洞发布日期: 2020/11/12

参考资料信息

CVE: CVE-2020-25694, CVE-2020-25695, CVE-2020-25696

IAVB: 2020-B-0069-S