NewStart CGSL CORE 5.05 / MAIN 5.05:python-virtualenv 多个漏洞 (NS-SA-2020-0118)

critical Nessus 插件 ID 143977

语言:

简介

远程机器受到多个漏洞影响。

描述

运行 CORE 5.05/MAIN 5.05 版本的远程 NewStart CGSL 主机上安装的 python-virtualenv 程序包受到多个漏洞的影响:

- 在适用于 Python 的 urllib3 库 1.24.1 及其之前版本中,如果攻击者控制请求参数,则可能发生 CRLF 注入。(CVE-2019-11236)

- urllib3 1.23 之前的版本未在进行跨源重定向后(即主机、端口或方案不同的重定向)移除授权 HTTP 标头。授权标头中的凭据可能因此泄露给非预期的主机,或以明文格式传输。(CVE-2018-20060)

- 适用于 Python 的请求程序包 2.20.0 之前的版本一经接收具有相同主机名称的 https-to-http 重定向,即会向 http URI 发送 HTTP 授权标头,从而使远程攻击者更容易通过探查网络发现凭据。(CVE-2018-18074)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号。

解决方案

升级易受攻击的 CGSL python-virtualenv 程序包。请注意,可能尚无可用的已更新程序包。请联系 ZTE 获取更多信息。

另见

http://security.gd-linux.com/notice/NS-SA-2020-0118

插件详情

严重性: Critical

ID: 143977

文件名: newstart_cgsl_NS-SA-2020-0118_python-virtualenv.nasl

版本: 1.4

类型: local

发布时间: 2020/12/9

最近更新时间: 2024/2/5

支持的传感器: Nessus

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.9

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS 分数来源: CVE-2018-20060

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:P/RL:O/RC:C

漏洞信息

必需的 KB 项: Host/local_checks_enabled, Host/cpu, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list

可利用: true

易利用性: Exploits are available

补丁发布日期: 2020/12/8

漏洞发布日期: 2018/3/26

参考资料信息

CVE: CVE-2018-18074, CVE-2018-20060, CVE-2019-11236

BID: 108793, 108815