MariaDB 10.4.0 < 10.4.16 Multiple Vulnerabilities

medium Nessus 插件 ID 142217

语言:

简介

远程数据库服务器受到多个漏洞的影响

描述

远程主机上安装的 MariaDB 版本低于 10.4.16。因此,如公告 mdb-10416-rn 所述,该主机受到多个漏洞的影响。

- Oracle MySQL 的 MySQL Server 产品中存在漏洞(组件:服务器:FTS)。支持的版本中受影响的是 5.6.49 和较早版本、5.7.31 和较早版本以及 8.0.21 和较早版本。可轻松利用的漏洞允许低权限攻击者通过多种协议进行网络访问,从而破坏 MySQL Server。成功攻击此漏洞可导致在未经授权的情况下造成 MySQL Server 挂起或频繁出现崩溃(完全 DOS)。(CVE-2020-14765)

- Oracle MySQL 的 MySQL Server 产品中存在漏洞(组件:InnoDB)。支持的版本中受影响的是 5.7.31 和较早版本以及 8.0.21 和较早版本。利用此漏洞的难度较低,通过多种协议进行网络访问的高权限攻击者可借此破坏 MySQL Server。成功攻击此漏洞可导致在未经授权的情况下造成 MySQL Server 挂起或频繁出现崩溃(完全 DOS)。(CVE-2020-14776)

- Oracle MySQL 的 MySQL Server 产品中存在漏洞(组件:服务器:FTS)。支持的版本中受影响的是 5.7.31 和较早版本以及 8.0.21 和较早版本。利用此漏洞的难度较低,通过多种协议进行网络访问的高权限攻击者可借此破坏 MySQL Server。成功攻击此漏洞可导致在未经授权的情况下造成 MySQL Server 挂起或频繁出现崩溃(完全 DOS)。(CVE-2020-14789)

- Oracle MySQL 的 MySQL Server 产品中存在漏洞(组件:Server: Locking)。支持的版本中受影响的是 5.6.49 和较早版本、5.7.31 和较早版本以及 8.0.21 和较早版本。利用此漏洞的难度较低,通过多种协议进行网络访问的高权限攻击者可借此破坏 MySQL Server。成功攻击此漏洞可导致在未经授权的情况下造成 MySQL Server 挂起或频繁出现崩溃(完全 DOS)。(CVE-2020-14812)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级至 MariaDB 10.4.16 或更高版本。

另见

https://mariadb.com/kb/en/mdb-10416-rn

插件详情

严重性: Medium

ID: 142217

文件名: mariadb_10_4_16.nasl

版本: 1.2

类型: remote

系列: Databases

发布时间: 2020/11/2

最近更新时间: 2020/11/2

配置: 启用偏执模式

风险信息

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5

矢量: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

时间矢量: CVSS2#E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2020-14812

CVSS v3

风险因素: Medium

基本分数: 4.9

时间分数: 4.3

矢量: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:*

必需的 KB 项: Settings/ParanoidReport

补丁发布日期: 2020/11/2

漏洞发布日期: 2020/10/21

参考资料信息

CVE: CVE-2020-14765, CVE-2020-14789, CVE-2020-14776, CVE-2020-14812