Oracle Java SE 1.7.0_281 / 1.8.0_271 / 1.11.0_9 / 1.15.0_1 多个漏洞(2020 年 10 月 CPU)

medium Nessus 插件 ID 141801

语言:

简介

远程主机受到多个漏洞的影响

描述

远程主机上安装的 Oracle(旧称 Sun)Java SE 或 Java for Business 的版本低于 7 Update 281、11 Update 9 或 15 Update 1。因此该应用程序会受到 2020 年 10 月 CPU 公告中提及的与以下组件相关的多个漏洞的影响:

- Oracle GraalVM 的 Oracle GraalVM Enterprise Edition 产品的漏洞(组件:Java)。
支持的版本中受影响的是 19.3.3 和 20.2.0。可以轻松利用的漏洞允许未经身份验证的攻击者通过多种协议进行网络访问,从而危害 Oracle GraalVM Enterprise Edition。成功攻击此漏洞可导致在未经授权的境况下,对 Oracle GraalVM Enterprise Edition 可访问数据的子集进行读取访问。(CVE-2020-14803)

- Oracle Java SE 的 Java SE、Java SE Embedded 产品中存在漏洞(组件:Hotspot)。支持的版本中受影响的是 Java SE:7u271、8u261、11.0.8 和 15;Java SE Embedded:8u261。难以利用的漏洞允许未经身份验证的攻击者通过多种协议进行网络访问,从而破坏 Java SE、Java SE Embedded。除攻击者以外的他人进行交互是实现成功攻击的必要条件。成功利用此漏洞进行攻击可导致在未经授权的情况下更新、插入或删除某些 Java SE、Java SE Embedded 可访问数据的访问权限,以及对 Java SE、Java SE Embedded 可访问数据子集进行未经授权的读取访问。注意:适用于 Java 客户端和服务器部署。此漏洞能通过需要在沙盒中运行的 Java Web Start 应用程序和需要在沙盒中运行的 Java 小程序加以利用。它也可通过向指定组件中的 API 提供数据而遭到利用,不使用需要在沙盒中运行的 Java Web Start 应用程序或需要在沙盒中运行的 Java 小程序,例如通过 Web 服务。
(CVE-2020-14792)

- Oracle Java SE 的 Java SE、Java SE Embedded 产品中存在漏洞(组件:JNDI)。支持的版本中受影响的是 Java SE:7u271、8u261、11.0.8 和 15;Java SE Embedded:8u261。难以利用的漏洞允许未经身份验证的攻击者通过多种协议进行网络访问,从而破坏 Java SE、Java SE Embedded。成功攻击此漏洞可导致对 Java SE、Java SE Embedded 可访问数据子集进行未经授权的读取访问。注意:适用于 Java 客户端和服务器部署。此漏洞能通过需要在沙盒中运行的 Java Web Start 应用程序和需要在沙盒中运行的 Java 小程序加以利用。它也可通过向指定组件中的 API 提供数据而遭到利用,不使用需要在沙盒中运行的 Java Web Start 应用程序或需要在沙盒中运行的 Java 小程序,例如通过 Web 服务。(CVE-2020-14781)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

根据 2020 年 10 月 Oracle 关键修补程序更新报告应用相应修补程序。

另见

https://www.oracle.com/a/tech/docs/cpuoct2020cvrf.xml

https://www.oracle.com/security-alerts/cpuoct2020.html

插件详情

严重性: Medium

ID: 141801

文件名: oracle_java_cpu_oct_2020_unix.nasl

版本: 1.7

类型: local

代理: unix

系列: Misc.

发布时间: 2020/10/22

最近更新时间: 2022/5/11

支持的传感器: Nessus Agent

风险信息

CVSS 分数来源: CVE-2020-14792

VPR

风险因素: Low

分数: 3.3

CVSS v2

风险因素: Medium

基本分数: 5.8

时间分数: 4.3

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 5.3

时间分数: 4.6

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:oracle:jre, cpe:/a:oracle:jdk

必需的 KB 项: Host/Java/JRE/Installed

易利用性: No known exploits are available

补丁发布日期: 2020/10/20

漏洞发布日期: 2020/10/20

参考资料信息

CVE: CVE-2020-14779, CVE-2020-14781, CVE-2020-14782, CVE-2020-14792, CVE-2020-14796, CVE-2020-14797, CVE-2020-14798, CVE-2020-14803

IAVA: 2020-A-0477-S