JQuery 1.2 < 3.5.0 多个 XSS

medium Nessus 插件 ID 136929
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器受到多个跨站脚本漏洞的影响。

描述

根据脚本中自我报告的版本,远程 Web 服务器上托管的 JQuery 版本介于 1.2 (含)和 3.5.0 之间。因此,该库受到多个跨站脚本漏洞的影响。

请注意,此插件中提及的漏洞对 PAN-OS 无安全影响,和/或在运行 PAN-OS 版本的设备上不存在成功利用此漏洞所需的场景。

解决方案

升级至 JQuery 3.5.0 或更高版本。

另见

https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/

https://security.paloaltonetworks.com/PAN-SA-2020-0007

插件详情

严重性: Medium

ID: 136929

文件名: jquery_cve-2020-11022.nasl

版本: 1.9

类型: remote

发布时间: 2020/5/28

最近更新时间: 2021/4/15

依存关系: jquery_detect.nasl, palo_alto_version.nbin, cisco_wlc_version.nasl

风险信息

CVSS 分数来源: CVE-2020-11022

VPR

风险因素: Medium

分数: 4.6

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.4

矢量: AV:N/AC:M/Au:N/C:N/I:P/A:N

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 6.1

时间分数: 5.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

时间矢量: E:P/RL:O/RC:C

漏洞信息

必需的 KB 项: installed_sw/jquery

排除的 KB 项: Host/Palo_Alto/Firewall/Version, Host/Cisco/WLC/Version

可利用: true

易利用性: Exploits are available

补丁发布日期: 2020/4/10

漏洞发布日期: 2020/4/29

参考资料信息

CVE: CVE-2020-11022, CVE-2020-11023

IAVB: 2020-B-0030