WordPress 插件“LearnPress”< 3.2.6.8 多个漏洞

high Nessus 插件 ID 136191

简介

远程 WordPress 应用程序中安装有容易受到多个漏洞影响的插件。

描述

远程主机上运行的 WordPress 应用程序配备版本低于 3.2.6.8 的“LearnPress”插件,因此受到多个漏洞的影响:

- LP_Modal_Search_Items 类的 the _get_items 方法中存在 SQL 注入 (SQLi) 漏洞,这是未正确验证用户提供的输入所致。经过身份验证的远程攻击者可利用此漏洞,在后端数据库中注入或操纵 SQL 查询,进而泄露或操纵任意数据。(CVE-2020-6010)

- learn_press_accept_become_a_teacher 函数中存在权限提升漏洞,这是代码未检查请求用户的权限所致。未经身份验证的远程攻击者可利用此漏洞,通过 /wpadmin/ 获取应用程序的“教师”访问权限。(CVE-2020-11511)

请注意,Nessus 并未试图利用这些问题,而是只依靠应用程序自我报告的版本号。

解决方案

通过管理仪表板,将“LearnPress”插件更新至 3.2.6.8 或更高版本。

另见

http://www.nessus.org/u?b38b6cba

https://wordpress.org/plugins/learnpress/#developers

插件详情

严重性: High

ID: 136191

文件名: wordpress_plugin_learnpress_3_2_6_8.nasl

版本: 1.5

类型: remote

系列: CGI abuses

发布时间: 2020/5/1

最近更新时间: 2022/5/13

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5.3

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

CVSS 分数来源: CVE-2020-11511

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 7.9

矢量: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:P/RL:O/RC:C

CVSS 分数来源: CVE-2020-6010

漏洞信息

CPE: cpe:/a:wordpress:wordpress

必需的 KB 项: installed_sw/WordPress, www/PHP

可利用: true

易利用性: Exploits are available

补丁发布日期: 2020/3/30

漏洞发布日期: 2020/3/30

参考资料信息

CVE: CVE-2020-6010, CVE-2020-11511