PHP 7.4.x < 7.4.5 urldecode OOB 读取

high Nessus 插件 ID 135969

语言:

简介

远程 Web 服务器上运行的 PHP 版本受到越界读取漏洞的影响。

描述

根据其自我报告的版本号,远程 Web 服务器上运行的 PHP 版本是低于 7.4.5 的 7.4.x。因此,该应用程序受到 urldecode() 中的越界读取错误影响,这是未正确检查数据验证所致。攻击者可插入负十六进制值,进而利用此漏洞,泄露在数组之前的内存中找到的值。

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号。

解决方案

升级至 PHP 7.4.5 或更高版本。

另见

http://www.nessus.org/u?948f4dd6

http://www.nessus.org/u?a7727efb

插件详情

严重性: High

ID: 135969

文件名: php_7_4_5.nasl

版本: 1.5

类型: remote

系列: CGI abuses

发布时间: 2020/4/24

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:P/I:N/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2020-7067

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP, installed_sw/PHP

易利用性: No known exploits are available

补丁发布日期: 2020/4/16

漏洞发布日期: 2020/4/16

参考资料信息

CVE: CVE-2020-7067

IAVA: 2020-A-0169-S