PHP 7.3.x < 7.3.16 多个漏洞

high Nessus 插件 ID 134944

简介

远程 Web 服务器上运行的 PHP 版本受到多个漏洞的影响。

描述

据标题可知,远程 Web 服务器上运行的 PHP 版本为低于 7.3.16 的 7.3.x。因此,该服务器受到以下漏洞的影响:

- 导致在 Exif 中使用未初始化值的越界读取 (CVE-2020-7064)

- mb_strtolower() 中的堆栈缓冲区溢出允许使用 .rodata 中的溢出数组覆写堆栈分配的缓冲区。(CVE-2020-7065)

- get_headers() 静默截断其使用的 URL 中空字节之后的所有内容。未经身份验证的远程攻击者可利用此漏洞泄露敏感信息,或使 Web 服务器意外处理攻击者控制的数据。(CVE-2020-7066) 请注意,Nessus 并未测试此问题,而是只依靠应用程序自我报告的版本号。

解决方案

升级至 PHP 7.3.16 或更高版本。

另见

https://www.php.net/ChangeLog-7.php#7.3.16

插件详情

严重性: High

ID: 134944

文件名: php_7_3_16.nasl

版本: 1.5

类型: remote

系列: CGI abuses

发布时间: 2020/3/27

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2020-7065

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 7.7

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP, installed_sw/PHP

易利用性: No known exploits are available

补丁发布日期: 2020/3/19

漏洞发布日期: 2020/3/19

参考资料信息

CVE: CVE-2020-7064, CVE-2020-7065, CVE-2020-7066

IAVA: 2020-A-0117-S