PHP 7.4.x < 7.4.0 多个漏洞。

critical Nessus 插件 ID 131732
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程主机上安装的应用程序受到多个漏洞影响。

描述

根据其标题,远程 Web 服务器上运行的 PHP 版本为低于 7.4.0 的 7.4.x 。因此,受到多个漏洞的影响,包括缓冲区溢出

解决方案

升级至 PHP 版本 7.4.0 或更高版本。

另见

https://www.php.net/ChangeLog-7.php#7.4

https://bugs.php.net/bug.php?id=72530

插件详情

严重性: Critical

ID: 131732

文件名: php_7_4_0.nasl

版本: 1.4

类型: remote

系列: CGI abuses

发布时间: 2019/12/6

最近更新时间: 2020/3/6

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2019-11043

VPR

风险因素: Critical

分数: 9

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.2

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:F/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 9.1

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:F/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP, installed_sw/PHP

可利用: true

易利用性: Exploits are available

补丁发布日期: 2019/8/29

漏洞发布日期: 2019/8/29

可利用的方式

Metasploit (PHP-FPM Underflow RCE)

参考资料信息

CVE: CVE-2019-11041, CVE-2019-11042, CVE-2019-11043