EulerOS Virtualization for ARM 64 3.0.3.0:haproxy (EulerOS-SA-2019-2329)

high Nessus 插件 ID 131494

简介

远程 EulerOS Virtualization for ARM 64 主机缺少多个安全更新。

描述

根据安装的 haproxy 程序包版本,远程主机上的 EulerOS Virtualization for ARM 64 安装会受到下列漏洞影响:- 在 HAProxy 1.8.14 及之前版本中,在 dns.c 的 dns_validate_dns_response 中发现一个越界读取。由于在验证 DNS 响应时遗漏检查,远程攻击者可能能够读取来自缓冲区尚未初始化部分对应至 AAAA 记录的 16 字节,并可能访问任何遗留在堆栈上的信息,或甚至超过 8193 字节缓冲区的终点,取决于 accepted_payload_size 的值。(CVE-2018-20102) 到 1.8.14 为止的所有版本,在 HAProxy 的 dns.c 中发现一个问题。在压缩指针的情况中,特制数据包通过使指针指向自身触发无限循环,或创建一长串有效指针来造成堆栈耗尽。(CVE-2018-20103) - 在 HAProxy 1.8.x 和 1.9.x 到 1.9.0 的 HTTP/2 协议解码器中发现越界读取问题,可能会导致崩溃。处理标头帧中的优先级标记需要 5 个额外字节,并且当跳过这些字节时,并未重新检查总帧长度以确保这些字节存在于帧内。(CVE-2018-20615) 请注意,Tenable Network Security 已直接从 EulerOS 安全公告中提取上述描述块。Tenable 已尝试在不引入其他问题的情况下尽可能进行了自动整理和排版。

解决方案

更新受影响的 haproxy 程序包。

另见

http://www.nessus.org/u?dc00cdfc

插件详情

严重性: High

ID: 131494

文件名: EulerOS_SA-2019-2329.nasl

版本: 1.5

类型: local

发布时间: 2019/12/3

最近更新时间: 2024/4/8

支持的传感器: Nessus

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS 分数来源: CVE-2018-20102

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:huawei:euleros:haproxy, cpe:/o:huawei:euleros:uvp:3.0.3.0

必需的 KB 项: Host/local_checks_enabled, Host/cpu, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/uvp_version

易利用性: No known exploits are available

补丁发布日期: 2019/12/3

参考资料信息

CVE: CVE-2018-20102, CVE-2018-20103, CVE-2018-20615