Exim < 4.92.1 输入验证 RCE

critical Nessus 插件 ID 128036
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程邮件服务器可能受到远程代码执行漏洞的影响。

描述

根据其标题,远程主机上运行的 Exim 版本低于 4.92.1。因此可能会受到 ‘${sort }’ 扩展中的输入验证缺陷影响。远程攻击者可能执行任意代码。请注意,默认配置不包含 ‘${sort }’。

解决方案

升级到 Exim 4.92.1 或更高版本。

另见

https://exim.org/static/doc/security/CVE-2019-13917.txt

https://ftp.exim.org/pub/exim/exim4/ChangeLog

插件详情

严重性: Critical

ID: 128036

文件名: exim_4_92_1.nasl

版本: 1.3

类型: remote

发布时间: 2019/8/20

最近更新时间: 2019/10/17

依存关系: smtpserver_detect.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2019-13917

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Critical

基本分数: 10

时间分数: 7.4

矢量: AV:N/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:exim:exim

必需的 KB 项: Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2019/7/18

漏洞发布日期: 2019/7/18

参考资料信息

CVE: CVE-2019-13917

BID: 109338