PHP 7.1.x < 7.1.29 堆基于堆的缓冲区溢出漏洞。

critical Nessus 插件 ID 124762
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程主机上的应用程序受到基于堆的缓冲区溢出漏洞的影响。

描述

根据其标题,远程 Web 服务器上运行的 PHP 版本为低于 7.1.29 的 7.1.x。因此在 exif.c 脚本中,受到 exif_process_IFD_TAG 之 _estrndup 内的一个基于堆的缓冲区过度读取情况的影响。未经身份验证的远程攻击者可利用此问题造成拒绝服务情况或执行任意代码。

解决方案

升级至 PHP 版本 7.1.29 或更高版本。

另见

http://php.net/ChangeLog-7.php#7.1.29

插件详情

严重性: Critical

ID: 124762

文件名: php_7_1_29.nasl

版本: 1.3

类型: remote

系列: CGI abuses

发布时间: 2019/5/10

最近更新时间: 2019/10/30

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2019-11036

VPR

风险因素: Medium

分数: 5.2

CVSS v2

风险因素: Medium

基本分数: 6.4

时间分数: 4.7

矢量: AV:N/AC:L/Au:N/C:P/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.1

时间分数: 7.9

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No known exploits are available

补丁发布日期: 2019/5/2

漏洞发布日期: 2019/4/29

参考资料信息

CVE: CVE-2019-11036