EulerOS Virtualization 2.5.4:ghostscript (EulerOS-SA-2019-1202)

medium Nessus 插件 ID 123888

语言:

全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 EulerOS Virtualization 主机缺少多个安全更新。

描述

根据安装的 ghostscript 程序包版本,远程主机上安装的 EulerOS Virtualization 会受到下列漏洞影响:- 据发现,ghostscript 未正确限制在启用 -dSAFER 模式之前开启之文件的访问。攻击者可利用此问题绕过 -dSAFER 保护并通过特制的 PostScript 文档泄露受影响的文件内容。(CVE-2018-16539) 发现 ghostscript 设备清理未能正确处理替换为空设备的设备。攻击者可能利用此问题绕过 -dSAFER 保护并导致 ghostscript 崩溃,或可能通过特制的 PostScript 文档在 ghostscript 环境中执行任意代码。(CVE-2018-16541) 请注意,Tenable Network Security 已直接从 EulerOS 安全公告中提取上述描述块。Tenable 已尝试在不引入其他问题的情况下尽可能进行了自动整理和排版。

解决方案

更新受影响的 ghostscript 程序包。

另见

http://www.nessus.org/u?de9a65be

插件详情

严重性: Medium

ID: 123888

文件名: EulerOS_SA-2019-1202.nasl

版本: 1.20

类型: local

发布时间: 2019/4/9

最近更新时间: 2021/1/6

依存关系: ssh_get_info.nasl

风险信息

CVSS 分数来源: CVE-2018-16539

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.2

矢量: AV:N/AC:M/Au:N/C:P/I:N/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 5.5

时间分数: 4.8

矢量: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:huawei:euleros:ghostscript, cpe:/o:huawei:euleros:uvp:2.5.4

必需的 KB 项: Host/local_checks_enabled, Host/cpu, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/uvp_version

易利用性: No known exploits are available

补丁发布日期: 2019/4/2

参考资料信息

CVE: CVE-2018-16539, CVE-2018-16541