Drupal 8.5.x < 8.5.11 / 8.6.x < 8.6.10 远程代码执行 (SA-CORE-2019-003)

high Nessus 插件 ID 122349
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

PHP 应用程序上运行的远程 Web 服务器受到一个远程代码执行漏洞影响。

描述

根据其自我报告的版本,远程 web 服务器上运行的 Drupal 实例为低于 8.5.11 的 8.5.x,或低于 8.6.10 的 8.6.x。因此,它受到一个远程代码执行漏洞影响,这是因为未正确审查非表单来源的数据所致。

解决方案

升级版本到 Drupal 8.5.11 / 8.6.10 或更高版本。

另见

https://www.drupal.org/sa-core-2019-003

https://www.drupal.org/project/drupal/releases/8.5.11

https://www.drupal.org/project/drupal/releases/8.6.10

插件详情

严重性: High

ID: 122349

文件名: drupal_8_6_10.nasl

版本: 1.9

类型: remote

系列: CGI abuses

发布时间: 2019/2/20

最近更新时间: 2019/10/31

依存关系: drupal_detect.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2019-6340

VPR

风险因素: Critical

分数: 9

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5.6

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:F/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 8.1

时间分数: 7.5

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:F/RL:O/RC:C

漏洞信息

CPE: cpe:/a:drupal:drupal

必需的 KB 项: installed_sw/Drupal, Settings/ParanoidReport

可利用: true

易利用性: Exploits are available

补丁发布日期: 2019/2/20

漏洞发布日期: 2019/2/20

可利用的方式

CANVAS (CANVAS)

Core Impact

Metasploit (Drupal RESTful Web Services unserialize() RCE)

参考资料信息

CVE: CVE-2019-6340