Apple iTunes < 12.9.3 多个漏洞(凭据检查)

critical Nessus 插件 ID 121473
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程主机上安装的应用程序受到多个漏洞的影响

描述

远程 Windows 主机上安装的 Apple iTunes 版本低于 12.9.3。因此,如公告 HT209450 所述,受到多个漏洞的影响:- 存在多个漏洞,这是因为 WebKit 组件中的输入处理缺陷所致。攻击者可利用其中一个漏洞,通过提供恶意的特制网络内容,在主机上执行任意代码。(CVE-2019-6212, CVE-2019-6215, CVE-2019-6216, CVE-2019-6217, CVE-2019-6226, CVE-2019-6227, CVE-2019-6233, CVE-2019-6234) - WebKit 组件中存在一个通用跨站脚本漏洞。攻击者可利用此漏洞,通过提供恶意的特制网络内容,在任何网站的安全环境中执行任意脚本。(CVE-2019-6229) - AppleKeyStore 组件中存在内存损坏漏洞。攻击者可利用此漏洞,允许进程避开沙盒限制。(CVE-2019-6235) - Core Media 组件中存在一个越界读取漏洞。攻击者可利用此漏洞,让恶意应用程序提升权限。(CVE-2019-6221) - SQLite 组件中存在多个内存损坏问题。攻击者可利用这些漏洞,通过执行恶意的 SQL 查询,在主机上执行任意代码。(CVE-2018-20346, CVE-2018-20505, CVE-2018-20506) 请注意,Nessus 并未针对这一问题进行测试,而仅依赖应用程序自我报告的版本号。

解决方案

升级到 Apple iTunes 版本 12.9.3 或更高版本。

另见

https://support.apple.com/en-us/HT209450

插件详情

严重性: Critical

ID: 121473

文件名: itunes_12_9_3.nasl

版本: 1.4

类型: local

代理: windows

系列: Windows

发布时间: 2019/1/30

最近更新时间: 2019/10/31

依存关系: itunes_detect.nasl

风险信息

CVSS 分数来源: CVE-2019-6235

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 10

时间分数: 9

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apple:itunes

必需的 KB 项: installed_sw/iTunes Version, SMB/Registry/Enumerated

可利用: true

易利用性: Exploits are available

补丁发布日期: 2019/1/24

漏洞发布日期: 2019/1/24

参考资料信息

CVE: CVE-2018-20346, CVE-2018-20505, CVE-2018-20506, CVE-2019-6212, CVE-2019-6215, CVE-2019-6216, CVE-2019-6217, CVE-2019-6221, CVE-2019-6226, CVE-2019-6227, CVE-2019-6229, CVE-2019-6233, CVE-2019-6234, CVE-2019-6235

BID: 106323, 106691, 106694, 106696, 106698, 106699, 106724

APPLE-SA: APPLE-SA-2019-1-24-1