Squid 3.1.12.1 <= 3.1.x <= 3.1.23 / 3.2.0.4 <= 3.2.x / 3.3.x / 3.4.x / 3.5.x <= 3.5.28 / 4.x < 4.4 跨站脚本漏洞 (SQUID-2018:4)

medium Nessus 插件 ID 119726

简介

远程代理服务器受到跨站脚本漏洞的影响。

描述

根据其标题,远程主机上运行的 Squid 版本是 3.1.12.1、3.1.23、3.1.12.1 之后且 3.1.23 之前的 3.1.x、3.2.0.4 或之后的 3.2.x、3.5.28 或之前的 3.3.x/3.4.x/3.5.x,或者 4.4 之前的 4.x。由于未正确验证用户提供的输入便将其返回给用户,因此受到跨站脚本 (XSS) 漏洞的影响。控制服务器的远程攻击者可利用此漏洞,通过触发向客户端发送已注入恶意脚本代码的错误页面,造成在客户端浏览器会话上执行。请注意,Nessus 没有测试此问题,而仅依赖于应用程序自我报告的版本号。

解决方案

升级到 Squid 4.4 或更高版本。或者,应用供应商提供的修补程序。

另见

http://www.squid-cache.org/Advisories/SQUID-2018_4.txt

插件详情

严重性: Medium

ID: 119726

文件名: squid_2018_4.nasl

版本: 1.2

类型: remote

系列: Firewalls

发布时间: 2018/12/17

最近更新时间: 2019/10/31

配置: 启用偏执模式

风险信息

VPR

风险因素: Low

分数: 3

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.2

矢量: AV:N/AC:M/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2018-19131

CVSS v3

风险因素: Medium

基本分数: 6.1

时间分数: 5.3

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:squid-cache:squid

必需的 KB 项: installed_sw/Squid, Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2016/10/17

漏洞发布日期: 2018/10/28

参考资料信息

CVE: CVE-2018-19131