Squid 3.x < 3.5.18 / 4.x < 4.0.10 多个拒绝服务漏洞 (SQUID-2016:9)

high Nessus 插件 ID 119723

简介

远程代理服务器受到多个拒绝服务漏洞的影响。

描述

根据其标题,远程主机上运行的 Squid 版本为低于 3.5.18 的 3.x 或低于 4.0.10 的 4.x。因此,由于不正确的指针处理和引用计数,ESI 响应处理组件受到多个拒绝服务 (DoS) 漏洞影响。控制服务器的远程攻击者可利用此问题,通过特制的 ESI 响应,对访问 Squid 服务的所有客户端造成拒绝服务。请注意,Nessus 没有测试此问题,而仅依赖于应用程序自我报告的版本号。

解决方案

升级到 Squid 3.5.18 或 4.0.10 或更高版本。或者,应用供应商提供的修补程序。

另见

http://www.squid-cache.org/Advisories/SQUID-2016_9.txt

插件详情

严重性: High

ID: 119723

文件名: squid_2016_9.nasl

版本: 1.2

类型: remote

系列: Firewalls

发布时间: 2018/12/17

最近更新时间: 2019/10/31

配置: 启用偏执模式

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2016-4555

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:squid-cache:squid

必需的 KB 项: installed_sw/Squid, Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2016/5/6

漏洞发布日期: 2016/5/6

参考资料信息

CVE: CVE-2016-4555, CVE-2016-4556