PHP < 4.3.3 多种漏洞

high Nessus 插件 ID 11850

语言:

简介

可以在远程服务器上运行任意代码。

描述

远程服务器运行的 PHP 版本低于 4.3.3。

低于 4.3.3 的所有 PHP 4 版本包含多种整数溢出漏洞,可能会允许攻击者在此主机上执行任意命令。另一个问题也可能会使 safe_mode 无效。

解决方案

请升级到 PHP 4.3.3。

另见

http://www.php.net/ChangeLog-4.php

插件详情

严重性: High

ID: 11850

文件名: php4_multiple_flaws.nasl

版本: 1.36

类型: remote

系列: CGI abuses

发布时间: 2003/9/24

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

漏洞发布日期: 2002/12/27

参考资料信息

CVE: CVE-2002-1396, CVE-2003-0442, CVE-2003-0860, CVE-2003-0861

BID: 6488, 7761, 8693, 8696

RHSA: 2003:204-01

SuSE: SUSE-SA:2003:0009