libssh 0.6.x / 0.7.x < 0.7.6 / 0.8.x < 0.8.4 认证绕过(远程版本检查)

critical Nessus 插件 ID 118155

简介

远程服务器易受到认证绕过的攻击。

描述

根据其标题版本,基于远程 libssh 的服务器易受到认证绕过的影响。攻击者可通过提供 SSH2_MSG_USERAUTH_SUCCESS 消息代替 SSH2_MSG_USERAUTH_REQUEST 方法(通常会启动认证)以绕过认证。

请注意,Nessus 未对此缺陷进行实际测试,而是依赖 libssh 标题中的版本,因此这可能是误报。

解决方案

升级到 libssh 0.7.6 / 0.8.4 或更高版本。

另见

http://www.nessus.org/u?6f6b157e

插件详情

严重性: Critical

ID: 118155

文件名: libssh_0_8_4.nasl

版本: 1.16

类型: remote

系列: Misc.

发布时间: 2018/10/17

最近更新时间: 2020/5/15

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2018-10933

VPR

风险因素: High

分数: 7.7

CVSS v2

风险因素: Medium

基本分数: 6.4

时间分数: 5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:N

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.1

时间分数: 8.2

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

时间矢量: E:P/RL:O/RC:C

漏洞信息

必需的 KB 项: Settings/ParanoidReport

可利用: true

易利用性: Exploits are available

漏洞发布日期: 2018/10/16

参考资料信息

CVE: CVE-2018-10933

IAVA: 2018-A-0347-S