Apache Struts 2.x < 2.3.16.2 Multiple ClassLoader Manipulation Vulnerabilities (S2-021)

high Nessus 插件 ID 117457

简介

远程主机上运行的 Web 应用程序使用受多个类加载器操作漏洞影响的 Java 框架。

描述

远程主机上运行的 Apache Struts 版本为低于 2.3.16.2 的 2.x。因而受到多个类加载器漏洞的影响。请注意,Nessus 并未测试这些问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级到 Apache Struts 2.3.16.2 或更高版本

另见

http://www.nessus.org/u?736174c4

插件详情

严重性: High

ID: 117457

文件名: struts_2_3_16_2.nasl

版本: 1.12

类型: combined

代理: windows, macosx, unix

系列: Misc.

发布时间: 2018/9/12

最近更新时间: 2022/4/11

配置: 启用彻底检查

支持的传感器: Frictionless Assessment Agent, Nessus Agent

风险信息

VPR

风险因素: High

分数: 7.4

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.2

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:F/RL:OF/RC:C

CVSS 分数来源: CVE-2014-0113

CVSS v3

风险因素: High

基本分数: 7.3

时间分数: 6.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

时间矢量: E:F/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:struts

可利用: true

易利用性: Exploits are available

补丁发布日期: 2014/4/24

漏洞发布日期: 2014/4/24

可利用的方式

Metasploit (Apache Struts ClassLoader Manipulation Remote Code Execution)

Elliot (Apache-Struts DefaultActionMapper < 2.3.15.1 RCE Linux)

参考资料信息

CVE: CVE-2014-0112, CVE-2014-0113

BID: 61189, 61196