Apache 2.4.x < 2.4.34 多个漏洞

high Nessus 插件 ID 111788

简介

远程 Web 服务器受到多个漏洞影响。

描述

根据其标题,远程主机上运行的 Apache 版本为低于 2.4.34 的 2.4.x。因此,该应用程序受到以下漏洞的影响:

- 通过特别构建 HTTP/2 请求,可将工作进程分配为长于所需的 60 秒,导致工作进程耗尽及拒绝服务。(CVE-2018-1333)

- 通过特别构建 HTTP 请求,mod_md 质询处理程序将取消空指针引用并造成子进程段错误。这可用于造成服务器拒绝服务。(CVE-2018-8011)

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号。

解决方案

升级至 Apache 2.4.34 或更高版本。

另见

https://archive.apache.org/dist/httpd/CHANGES_2.4.34

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.34

插件详情

严重性: High

ID: 111788

文件名: apache_2_4_34.nasl

版本: 1.10

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2018/8/16

最近更新时间: 2022/4/11

配置: 启用彻底检查

支持的传感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2018-1333

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:http_server, cpe:/a:apache:httpd

必需的 KB 项: installed_sw/Apache

易利用性: No known exploits are available

补丁发布日期: 2018/7/15

漏洞发布日期: 2018/7/15

参考资料信息

CVE: CVE-2018-1333, CVE-2018-8011

IAVA: 2021-A-0259-S