Drupal 7.x < 7.58 / 8.3.x < 8.3.9 / 8.4.x < 8.4.6 / 8.5.x < 8.5.1 远程代码执行漏洞 (SA-CORE-2018-002)

critical Nessus 插件 ID 108688

简介

PHP 应用程序上运行的远程 Web 服务器受到一个远程代码执行漏洞影响。

描述

根据自我报告的版本号,远程 Web 服务器上运行的 Drupal 实例版本是低于 7.58 的 7.x、低于 8.3.9 的 8.3.x、低于 8.4.6 的 8.4.x 或低于 8.5.1 的 8.5.x。因而会受到远程代码执行漏洞的影响。请注意,Nessus 并未测试这些问题,而是只依赖于应用程序自我报告的版本号。

解决方案

升级版本到 Drupal 7.58 / 8.3.9 / 8.4.6 / 8.5.1 或更高版本。

另见

https://www.drupal.org/SA-CORE-2018-002

https://www.drupal.org/project/drupal/releases/7.58

https://www.drupal.org/project/drupal/releases/8.3.9

https://www.drupal.org/project/drupal/releases/8.4.6

https://www.drupal.org/project/drupal/releases/8.5.1

插件详情

严重性: Critical

ID: 108688

文件名: drupal_8_5_1.nasl

版本: 1.19

类型: remote

系列: CGI abuses

发布时间: 2018/3/28

最近更新时间: 2022/4/11

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2018-7600

VPR

风险因素: Critical

分数: 9.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:H/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 9.4

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:H/RL:O/RC:C

漏洞信息

CPE: cpe:/a:drupal:drupal

必需的 KB 项: installed_sw/Drupal, Settings/ParanoidReport

可利用: true

易利用性: Exploits are available

补丁发布日期: 2018/3/28

漏洞发布日期: 2018/3/28

CISA 已知利用日期: 2022/5/3

可利用的方式

Core Impact

Metasploit (Drupal Drupalgeddon 2 Forms API Property Injection)

Elliot (Drupal 8 SA-CORE-2018-002 RCE)

参考资料信息

CVE: CVE-2018-7600