Debian DSA-4120-1:linux - 安全更新 (Meltdown) (Spectre)

high Nessus 插件 ID 106955

语言:

全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Debian 主机缺少与安全相关的更新。

描述

在 Linux 内核中发现多个可能导致权限升级、拒绝服务或信息泄漏的漏洞。- CVE-2017-5715 多名研究人员在多个支持推测执行的处理器中发现一个漏洞,攻击者可通过该漏洞控制非特权进程从任意地址读取内存,包括从内核和系统上运行的所有其他进程读取内存。这种特定的攻击称为 Spectre 变体 2(分支目标注入),在 Intel x86-64 架构的 Linux 内核中通过使用“retpoline”编译器功能予以缓解,该功能可实现间接分支与推测执行之间的隔离。- CVE-2017-5754 多名研究人员在 Intel 处理器中发现一个漏洞,攻击者可通过该漏洞控制非特权进程从任意地址读取内存,包括从内核和系统上运行的所有其他进程读取内存。这种特定的攻击已被命名为 Meltdown,在 powerpc/ppc64el 架构的 Linux 内核中通过从内核模式退出到用户模式(或从虚拟机管理程序退出到内核)时刷新 L1 数据缓存予以解决。此方案适用于 Power7、Power8 和 Power9 处理器。- CVE-2017-13166 在 v4l2 IOCTL 处理代码的 32 位兼容性层中发现一个错误。确保用户提供的缓冲区始终指向用户空间内存的内存保护遭到禁用,从而允许目的地位于内核空间中。攻击者可利用此错误覆盖非特权用户区进程的内核内存,从而导致权限提升。- CVE-2018-5750 在 Linux 内核中发现信息泄露。每次启动时,acpi_smbus_hc_add() 都会在内核日志中打印一个内核地址,系统上的攻击者可利用该地址破解内核 ASLR。除这些漏洞之外,此版本中还包含一些针对 CVE-2017-5753 的缓解措施。- CVE-2017-5753 多名研究人员在多个支持推测执行的处理器中发现一个漏洞,攻击者可通过该漏洞控制非特权进程从任意地址读取内存,包括从内核和系统上运行的所有其他进程读取内存。这种特定的攻击称为 Spectre 变体 1(边界检查绕过),在 Linux 内核架构中通过识别易受攻击的代码段(先检查数组边界,再访问数组),然后使用推测安全的 array_index_nospec() 函数替换数组访问来予以缓解。随着时间的推移,将会增加更多的使用站点。

解决方案

升级 linux 程序包。对于稳定发行版本 (stretch),已在版本 4.9.82-1~deb9u2 中修复这些问题。

另见

https://security-tracker.debian.org/tracker/CVE-2017-5715

https://security-tracker.debian.org/tracker/CVE-2017-5754

https://security-tracker.debian.org/tracker/CVE-2017-13166

https://security-tracker.debian.org/tracker/CVE-2018-5750

https://security-tracker.debian.org/tracker/CVE-2017-5753

https://security-tracker.debian.org/tracker/CVE-2017-5753

https://security-tracker.debian.org/tracker/source-package/linux

https://packages.debian.org/source/stretch/linux

https://www.debian.org/security/2018/dsa-4120

插件详情

严重性: High

ID: 106955

文件名: debian_DSA-4120.nasl

版本: 3.6

类型: local

代理: unix

发布时间: 2018/2/23

最近更新时间: 2019/7/15

依存关系: ssh_get_info.nasl

风险信息

VPR

风险因素: High

分数: 8.1

CVSS v2

风险因素: Medium

基本分数: 4.7

时间分数: 4.1

矢量: AV:L/AC:M/Au:N/C:C/I:N/A:N

时间矢量: E:H/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.8

时间分数: 7.5

矢量: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:H/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:debian:debian_linux:linux, cpe:/o:debian:debian_linux:9.0

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可利用: true

易利用性: Exploits are available

补丁发布日期: 2018/2/22

漏洞发布日期: 2017/12/6

参考资料信息

CVE: CVE-2017-13166, CVE-2017-5715, CVE-2017-5754, CVE-2018-5750

DSA: 4120

IAVA: 2018-A-0019, 2018-A-0020