JQuery 1.x < 1.12.0 / 2.x < 2.2.0 XSS

medium Nessus 插件 ID 106657
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器受到跨站脚本漏洞的影响。

描述

远程 Web 服务器上托管的 JQuery 库版本为低于 1.12.0 的 1.x 或低于 2.2.0 的 2.x。因此,当使用 location.host 选择元素时,受到跨站脚本漏洞的影响。

解决方案

请升级到 JQuery 版本 1.12.0 或更高版本。

另见

https://blog.jquery.com/2016/01/08/jquery-2-2-and-1-12-released/

插件详情

严重性: Medium

ID: 106657

文件名: jquery_2_2_0.nasl

版本: 1.6

类型: remote

发布时间: 2018/2/7

最近更新时间: 2020/11/24

依存关系: jquery_detect.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: manual

CVSS 分数理由: Score based on analysis of the vendor advisory.

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.7

矢量: AV:N/AC:M/Au:N/C:N/I:P/A:N

时间矢量: E:H/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 4.7

时间分数: 4.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

时间矢量: E:H/RL:O/RC:C

漏洞信息

CPE: cpe:/a:jquery:jquery

必需的 KB 项: Settings/ParanoidReport, installed_sw/jquery

易利用性: No exploit is required

补丁发布日期: 2015/9/10

漏洞发布日期: 2015/6/15