dnsmasq < 2.76 空地址拒绝服务 (CVE-2015-8899)

high Nessus 插件 ID 106138

简介

远程 DNS / DHCP 服务受到拒绝服务漏洞的影响。

描述

远程主机上安装的 dnsmasq 版本至少为 2.73,并低于 2.76,因此,当处理特定名称为空的回复,而 A 或 AAAA 记录被本地定义且位于主机文件中时,会受到拒绝服务漏洞的影响。

解决方案

升级到 dnsmasq 2.76 或更高版本。

另见

http://www.thekelleys.org.uk/dnsmasq/CHANGELOG

http://www.nessus.org/u?1481bb05

插件详情

严重性: High

ID: 106138

文件名: dnsmasq_2_76.nasl

版本: 1.5

类型: remote

系列: DNS

发布时间: 2018/1/18

最近更新时间: 2019/11/8

配置: 启用偏执模式

支持的传感器: Nessus

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS 分数来源: CVE-2015-8899

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:thekelleys:dnsmasq

必需的 KB 项: Settings/ParanoidReport, dns_server/version

易利用性: No known exploits are available

补丁发布日期: 2014/11/14

漏洞发布日期: 2016/4/18

参考资料信息

CVE: CVE-2015-8899

BID: 91031