Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Tenable 博客

订阅

CVE-2019-1579: Palo Alto Networks GlobalProtect SSL VPN 中的严重预身份验证漏洞被公开

Researchers disclose a critical vulnerability in Palo Alto GlobalProtect SSL VPN solution used by many organizations.

背景

On July 17, researchers Orange Tsai and Meh Chang published a blog about their discovery of a pre-authentication remote code execution (RCE) vulnerability in the Palo Alto Networks (PAN) GlobalProtect Secure Socket Layer (SSL) virtual private network (VPN) used by many organizations around the world.

分析

CVE-2019-1579 is a format string vulnerability in the PAN SSL Gateway, which handles client/server SSL handshakes. More specifically, the vulnerability exists because the gateway passes the value of a particular parameter to snprintf in an unsanitized, and exploitable, fashion. An unauthenticated attacker could exploit the vulnerability by sending a specially crafted request to a vulnerable SSL VPN target in order to remotely execute code on the system.

Though the researchers reported their findings to PAN, the company responded that the vulnerability had been identified internally and fixed, hence why no CVE identifier was assigned and why newer versions of GlobalProtect are not vulnerable.

From there, the researchers sought to identify whether any large organizations might be running a vulnerable version of GlobalProtect. They found that popular ride-hailing service, Uber, was running an unpatched version. They confirmed their exploit worked against Uber and reported their findings. Uber responded it did not use PAN SSL VPN as its “primary VPN” and that it was hosted on Amazon Web Services (AWS) and not a part of the organization’s “core infrastructure,” which mitigated some of the potential impact of this vulnerability.

We expect to see more incoming scans to identify organizations running vulnerable instances of the PAN SSL VPN in their environments.

概念验证

Tsai and Chang included a proof-of-concept (PoC) in their blog post, but it requires modification in order to work successfully. They also provided a command to help identify vulnerable GlobalProtect versions based on the login.css file (8.x) and a .gif file (7.x).

Vendor response

Since publication of Tsai and Chang’s blog, PAN has assigned a CVE identifier, CVE-2019-1579, and published a security advisory, PAN-SA-2019-0020, for it.

解决方案

The following table contains information about vulnerable versions and fixed or non-vulnerable versions of the PAN-OS:

Affected version Fixed version
PAN-OS 7.1.18 and earlier PAN-OS 7.1.19 and later
PAN-OS 8.0.11 and earlier PAN-OS 8.0.12 and later
PAN-OS 8.1.2 and earlier PAN-OS 8.1.3 and later

This vulnerability does not impact PAN-OS 9.0.

Additionally, PAN-SA-2019-0020 provides mitigations for customers who cannot upgrade to a patched version. The company recommends updating to “content release 8173, or a later version” as well as ensuring threat prevention is “enabled and enforced on traffic that passes through the GlobalProtect portal and GlobalProtect Gateway interface.”

识别受影响的系统

A list of Nessus plugins to identify this vulnerability will appear here as they’re released.

获取更多信息

加入 Tenable Community 中的 Tenable 安全响应团队

了解有关 Tenable 这款首创 Cyber Exposure 平台的更多信息,全面管理现代攻击面。

Get a free 60-day trial of Tenable.io.

相关文章

您是否易受最新漏洞利用的攻击?

输入您的电子邮件以在收件箱中接收最新的 Cyber Exposure 警报。

tenable.io

免费试用 30 天


可全面访问基于云的现代化漏洞管理平台,从而以无可比拟的精确度发现并追踪所有资产。

tenable.io 购买

可全面访问基于云的现代化漏洞管理平台,从而以无可比拟的精确度发现并追踪所有资产。 立即购买年度订阅。

65 项资产

选择您的订阅选项:

立即购买

免费试用 Nessus Professional

免费试用 7 天

Nessus® 是当今市场上功能最全面的漏洞扫描器。Nessus Professional 可帮助自动化漏洞扫描流程、节省合规周期的时间,并让您调动起 IT 团队的积极性。

购买 Nessus Professional

Nessus® 是当今市场上功能最全面的漏洞扫描器。Nessus Professional 可帮助自动化漏洞扫描流程、节省合规周期的时间,并让您调动起 IT 团队的积极性。

购买多年期许可,即享优惠价格添加高级支持功能,获取一年 365 天、一天 24 小时的电话、社区和聊天支持。

选择您的许可证

购买多年期许可,即享优惠价格

添加支持和培训

Tenable.io 免费试用 30 天

可全面访问基于云的现代化漏洞管理平台,从而以无可比拟的精确度发现并追踪所有资产。

Tenable.io 购买

可全面访问基于云的现代化漏洞管理平台,从而以无可比拟的精确度发现并追踪所有资产。 立即购买年度订阅。

65 项资产

选择您的订阅选项:

立即购买

试用 Tenable.io Web Application Scanning

免费试用 30 天

完整享有专为现代化应用程序而设、属于 Tenable.io 平台组成部分的最新 Web 应用程序扫描功能。可安全扫描全部在线资产组合的漏洞,具有高度准确性,而且无需繁重的手动操作或中断关键的 Web 应用程序。 立即注册。

购买 Tenable.io Web Application Scanning

可全面访问基于云的现代化漏洞管理平台,从而以无可比拟的精确度发现并追踪所有资产。 立即购买年度订阅。

5 个 FQDN

$3,578

立即购买

试用 Tenable.io Container Security

免费试用 30 天

完整获得已集成至漏洞管理平台之唯一容器安全产品的功能。监控容器映像中的漏洞、恶意软件和策略违规。与持续集成和持续部署 (CI/CD) 系统进行整合,以支持 DevOps 实践、增强安全性并支持企业政策合规。

购买 Tenable.io Container Security

Tenable.io Container Security 经由与构建流程的集成,可供全面了解容器映像的安全性,包括漏洞、恶意软件和策略违规,借以无缝且安全地启用 DevOps 流程。

试用 Tenable Lumin

免费试用 30 天

通过 Tenable Lumin 直观呈现及探索 Cyber Exposure,长期追踪风险降低状况,并比照同行业者进行基准度量。

购买 Tenable Lumin

联系销售代表,了解 Lumin 如何帮助获取整个企业的洞见并管理网络安全风险。

试用 Tenable.cs

免费试用 30 天 在软件开发生命周期的设计、构建和运行时阶段,享有检测和修复云基础架构错误配置的完全访问权限。

购买 Tenable.cs

联系销售代表,了解有关云安全的更多信息,以及如何从代码到云,全程护航。